Le Forum du Zèbre et des Zamiboostiens

Problème avec phpMyvisites

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Problème avec phpMyvisites

Message par aline jégonday le Lun 3 Jan 2011 - 16:21

Bonjour les amis et bonne année à tous,

Tiens donc ça commence avec un p'tit problème. Le lien dans mes favoris que j'utilise habituellement pour aller voir Php ne fonctionne plus comme avant (avant c'était il y a quelques jours) voici ce que ça donne,



et lorsque je clique dans login, et bien rien ne se passe.

J'ai remarqué aussi que sur mon site, les "balises" ?( c'est sûrement pas le bon terme...) php sont devenues visibles alors qu'auparavant je les avaient planquées sous des photos et cela marchait de cette façon depuis le début.

Merci à celui ou celle qui peut me répondre.

Edit Babyl : image retirée par sécurité, je l'ai remplacée en retirant et floutant les données personnelles

aline jégonday
Abonné
Abonné

Scorpion Chat
Nombre de messages : 155
Age : 65
Ville (CP) : Saintes. Charentes Maritimes
Date d'inscription : 12/06/2007

http://atelier-enila-tityad.fr

Revenir en haut Aller en bas

Résolu Re: Problème avec phpMyvisites

Message par B@byl le Lun 3 Jan 2011 - 18:03

Bonjour Aline
Oui bizarre ce truc
il dit qu'il ne trouve pas l'index.
Pour les balises php, si c'est bien ça, il ne faut jamais mettre du php dans une page html.

Je vais continuer par mp.


_________________
B@byl
"La qualité d'une vie n'est pas dans l'accumulation mais dans le partage"
avatar
B@byl
Conservateur
Conservateur

Balance Serpent
Nombre de messages : 5844
Age : 63
Ville (CP) : Pas d'entraide par MP ou mail
Date d'inscription : 07/02/2007

http://www.assmat-nantes.fr/

Revenir en haut Aller en bas

Résolu Re: Problème avec phpMyvisites

Message par B@byl le Mar 4 Jan 2011 - 16:00

@ Aline j'ai vu sur la copie écran en faite ce n'est pas une balise php mais simplement l'image phpmyvisite qui est remplacée par du texte car plus moyen d'avoir accès au contenu phpmyvisite alors que le dossier est bien présent sur ton serveur avec tout son contenu.

Je m'inquiète pour ta base de donnée, c'est comme si tu n'en avais plus.

Sur tous les fichiers php y compris ceux générés par cariboost je retrouve une très longue ligne codée exactement la même partout.
Si quelqu'un peut nous dire ce qu'il en pense en voici un bout sans les babises
eval(base64_decode('aWYoZnVuY3Rpb25fZXhpc3RzKCdvYl9zdGFydCcpJiYhaXNzZXQ

Je viens de trouver ça sur google http://leszed.ed-productions.com/evalbase64_decode-comment-les-virer/

je n'ai plus le temps de regarder de près, je reviens en fin soirée.
Je sens qu'on va avoir du boulot Aline.

PS : J'ai commencé le nettoyage manuellement.

_________________
B@byl
"La qualité d'une vie n'est pas dans l'accumulation mais dans le partage"
avatar
B@byl
Conservateur
Conservateur

Balance Serpent
Nombre de messages : 5844
Age : 63
Ville (CP) : Pas d'entraide par MP ou mail
Date d'inscription : 07/02/2007

http://www.assmat-nantes.fr/

Revenir en haut Aller en bas

Résolu Re: Problème avec phpMyvisites

Message par B@byl le Mar 4 Jan 2011 - 21:32

Bon il n'y a pas de doute tu as bien été hackée.
voilà j'ai tout nettoyé du moins j'espère qu'il n'y en a pas d'oubliés,
J'ai utilisé notepad qui se charge de chercher tous les fichiers et de supprimer automatiquement la ligne de code.

Ça y est l'interface est revenue comme avant, mais maintenant il faut que tu vérifies si tu peux entrer.

_________________
B@byl
"La qualité d'une vie n'est pas dans l'accumulation mais dans le partage"
avatar
B@byl
Conservateur
Conservateur

Balance Serpent
Nombre de messages : 5844
Age : 63
Ville (CP) : Pas d'entraide par MP ou mail
Date d'inscription : 07/02/2007

http://www.assmat-nantes.fr/

Revenir en haut Aller en bas

Résolu Re: Problème avec phpMyvisites

Message par aline jégonday le Mar 4 Jan 2011 - 21:42

ouiii i!!! ça fonctionne, je rentre bien sur ma page depuis le lien habituel. En fait c'était en panne depuis le 24 décembre. Il faudrait que je voie demain si j'ai des visites, normalement il y en a toujours un minimum tous les jours.

Mais, dis moi est-il dans ce cas nécessaire que je change ce fameux mot de passe ?
Pourquoi ce genre de truc arrive t-il et quel est le genre d'ollibrius qui fait ça dans quel intérêt ?

Je te dois encore une belle brassée de roses et un collier de bisous...

aline jégonday
Abonné
Abonné

Scorpion Chat
Nombre de messages : 155
Age : 65
Ville (CP) : Saintes. Charentes Maritimes
Date d'inscription : 12/06/2007

http://atelier-enila-tityad.fr

Revenir en haut Aller en bas

Résolu Re: Problème avec phpMyvisites

Message par B@byl le Mar 4 Jan 2011 - 22:02

J'ai fouiné un peu partout sur google et ils peuvent effectivement récupérer les identifiants et mots de passe ce serait apparemment une faille de chez phpmyvisite vérifie si tu as bien la version 2,4 car normalement elle devait corriger la faille.
Quand on ouvre c'est écrit tout en bas en gris très clair, c'est à peine visible.

Et curieusement les postes que j'ai trouvé sur ce problème datent d'un an et le problème c'était produit le 24 décembre 2009 juste 1 an avant.


Oui je pense que ce sera mieux de changer ton mot de passe bien que personne ne sait comment ils rentrent ce code mais ce sera plus sûr.

Pour cela il faut que tu ailles sur ton espace membre que tu changes le code d'accès à ton serveur et comme te le disait 1&1 il faudra aussi mettre ce nouveau code dans les paramètres de WA pour pouvoir publier.

Si ça te semble compliqué dis-moi et on verra demain pour ce changement de code.

Bien contente que ça a marché et merci notepad car phpmv contient plus de 1000 fichiers et plus de la moitié des php tous corrompus j'aurais mis plus d'une semaine à nettoyer plus de 500 fichiers 1 par 1.

_________________
B@byl
"La qualité d'une vie n'est pas dans l'accumulation mais dans le partage"
avatar
B@byl
Conservateur
Conservateur

Balance Serpent
Nombre de messages : 5844
Age : 63
Ville (CP) : Pas d'entraide par MP ou mail
Date d'inscription : 07/02/2007

http://www.assmat-nantes.fr/

Revenir en haut Aller en bas

Résolu Re: Problème avec phpMyvisites

Message par aline jégonday le Mar 4 Jan 2011 - 22:20

Oui, il me semble bien que j'ai la version 2.4 qui a été ré-installée lorsque j'ai changé d'ordi. Sinon, je ne vois pas le gris clair sur la page.
C'est déjà super pour aujourd'hui, nous reviendrons sur ce problème de changement de code plus tard si tu le veux bien car
je ne pense pas pouvoir le faire seule effectivement.
Re-merci Babyl et bonne fin de soirée.


aline jégonday
Abonné
Abonné

Scorpion Chat
Nombre de messages : 155
Age : 65
Ville (CP) : Saintes. Charentes Maritimes
Date d'inscription : 12/06/2007

http://atelier-enila-tityad.fr

Revenir en haut Aller en bas

Résolu Re: Problème avec phpMyvisites

Message par B@byl le Mar 4 Jan 2011 - 22:45

De rien c'est avec plaisir Aline surtout pour des problèmes de ce genre.

Sinon tu peux voir la version, toujours en bas de page en ouvrant l'onglet administration .

PS : Pour le changement de mot de passe je crois que Microbull sera plus apte que moi pour te conseiller car il est chez 1&1, nous verrons avec lui demain si il peut.

_________________
B@byl
"La qualité d'une vie n'est pas dans l'accumulation mais dans le partage"
avatar
B@byl
Conservateur
Conservateur

Balance Serpent
Nombre de messages : 5844
Age : 63
Ville (CP) : Pas d'entraide par MP ou mail
Date d'inscription : 07/02/2007

http://www.assmat-nantes.fr/

Revenir en haut Aller en bas

Résolu Re: Problème avec phpMyvisites

Message par aline jégonday le Mer 5 Jan 2011 - 8:13

OK. Merci. Je suppose que tout de même ce changement de code ne presse pas trop. Il ne faudrait pas qu'il y ait besoin d'une donnée d'origine pour appliquer ce changement dans mon cari V1 car c'est Pierre qui avait fait ce travail et j'ignore totalement comment.

aline jégonday
Abonné
Abonné

Scorpion Chat
Nombre de messages : 155
Age : 65
Ville (CP) : Saintes. Charentes Maritimes
Date d'inscription : 12/06/2007

http://atelier-enila-tityad.fr

Revenir en haut Aller en bas

Résolu Re: Problème avec phpMyvisites

Message par B@byl le Mer 5 Jan 2011 - 13:20

J'ai continué le travail avec des recherches sur google car netoyerles fichiers n'était probablement pas suffisant et j'ai bien fait car il restait les fichiers qui installent tout ça.

je viens de les retirer, donc de nouveau peux-tu retourner sur phpmv voir si tout marche toujours bien.
Et confirme-moi si tu as bien la 2,4.

Je vais faire un tuto de tout ce que j'ai appris ça pourra servir et ça me permettra de ne pas oublier comment j'ai procédé.

_________________
B@byl
"La qualité d'une vie n'est pas dans l'accumulation mais dans le partage"
avatar
B@byl
Conservateur
Conservateur

Balance Serpent
Nombre de messages : 5844
Age : 63
Ville (CP) : Pas d'entraide par MP ou mail
Date d'inscription : 07/02/2007

http://www.assmat-nantes.fr/

Revenir en haut Aller en bas

Résolu Re: Problème avec phpMyvisites

Message par aline jégonday le Mer 5 Jan 2011 - 17:03

Et ben dis donc j'étais bien loin de penser à tous ces problèmes. Oui je pense avoir la version 2.4 : si je vais dans administration, j'ai ça :


Si il n'y avait pas le forum il y a belle lurette que je n'aurai plus de site !


aline jégonday
Abonné
Abonné

Scorpion Chat
Nombre de messages : 155
Age : 65
Ville (CP) : Saintes. Charentes Maritimes
Date d'inscription : 12/06/2007

http://atelier-enila-tityad.fr

Revenir en haut Aller en bas

Résolu Re: Problème avec phpMyvisites

Message par aline jégonday le Mer 5 Jan 2011 - 17:04

J'ai oublié : oui ça fonctionne bien.

aline jégonday
Abonné
Abonné

Scorpion Chat
Nombre de messages : 155
Age : 65
Ville (CP) : Saintes. Charentes Maritimes
Date d'inscription : 12/06/2007

http://atelier-enila-tityad.fr

Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum