Le Forum du Zèbre et des Zamiboostiens

Analyse du site par W3C

Voir le sujet précédent Voir le sujet suivant Aller en bas

Résolu Analyse du site par W3C

Message par nadia cecile le Dim 17 Mar 2013 - 18:53

W3C

De nadia cecile A nadia cecile, Aujourd'hui à 17:51

Bonjour,

L'analyse de mon site par W3C, fait ressortir 10 erreurs sur mon site.
J'ai copié collé les erreurs ci-dessous.
Je souhaiterai les corriger, mais je ne sais pas comment faire.
Merci de m'éclairer sur la façon de procéder.

Cordialement,
Nadia Cécile

Sortie de validation: 10 erreurs

Code:
1.    Ligne 105, colonne 245 : balise de fin pour "img" omise, mais OMITTAG NO a été spécifiée
0076608_31c7e1cca7_n.jpg ... "width =" 320 "height =" 240 "alt =" Moment de douceur ">

Vous avez peut être oublié de fermer un élément, ou peut-être que vous voulez dire à «l'auto-close" un élément, c'est à dire qu'elle se terminant par "/>" au lieu de ">".

2.    Ligne 105, colonne 119 : balise de début était ici
... Douceur de lavillacecile, sur Flickr "> < img src = "http://farm9.staticflickr.com/ ...

3.    Ligne 111, colonne 118 : "allowFullScreen" n'est pas membre d'un groupe défini pour un attribut
Youtube.com/embed/xVlXCOl2tNE ....? Rel = 0 "frameborder =" 0 "allowFullScreen >

4.    Ligne 118, colonne 8 : requis attribut "type" non spécifiée
(function (d, s, id) {

L'attribut donné ci-dessus est nécessaire pour un élément que vous avez utilisé, mais vous avez omis. Par exemple, dans la plupart des types de documents HTML et XHTML du attribut "type" est nécessaire sur le "script" élément et l'attribut "alt" est nécessaire pour le "img" élément.
Les valeurs typiques pour Type sont de type = "text / css" pour


Dernière édition par nadia cecile le Mar 19 Mar 2013 - 17:51, édité 1 fois
avatar
nadia cecile
Touriste
Touriste

Bélier Buffle
Nombre de messages : 38
Age : 56
Ville (CP) : 17700
Date d'inscription : 13/02/2012

http://www.lavillacecile.fr

Revenir en haut Aller en bas

Résolu Re: Analyse du site par W3C

Message par B@byl le Lun 18 Mar 2013 - 14:23

Bonjour

Décidément, pas de chance encore mauvaise pioche.

Ton sujet était dans utilisation du forum, franchement un petit effort, il est clair que ton problème ne concerne pas le fonctionnement du forum mais la création de ton site.
Si tu cliques sur le bouton accueil du menu du forum tu as des catégories et sous catégories très clairement indiquées, ce n'est pourtant pas compliqué de choisir la bonne, celle qui correspond à ton problème.
Donc voilà j'ai encore fait le ménage. Very Happy

Bon, passons à ton problème je reprends par les numérotations que tu as indiquées :

1. Tu as inséré un code pour image qui se termine par
Code:
alt =" Moment de douceur ">
Il y a erreur de codage, tu remplaceras cette fin par :
Code:
alt =" Moment de douceur " />


2. la correction de 1 corrigera aussi la 2 (ne pas s'en préoccuper)

3. Youtube utilise un attribut qui n'est pas accepté par le W3C qui est allowfullscreen, je pense que tu peux le supprimer sans que ça gêne le fonctionnement de la vidéo, tu peux toujours essayer, tu verras ce que ça donne.
Ton code Youtube se termine comme ça :
Code:
frameborder="0" allowfullscreen></iframe>
Modifie la fin comme ceci :
Code:
frameborder="0"></iframe>

4. Tu as un script pour faceBook et dans ta balise le type de ce script n'est pas indiqué, c'est du javascript il faut donc que tu remplaces cette balise :
Code:
<script>
par
Code:
<script type="text/javascript">

Bien cordialement

_________________
B@byl
"La qualité d'une vie n'est pas dans l'accumulation mais dans le partage"
avatar
B@byl
Conservateur
Conservateur

Balance Serpent
Nombre de messages : 5872
Age : 64
Ville (CP) : Pas d'entraide par MP ou mail
Date d'inscription : 07/02/2007

http://www.assmat-nantes.fr/

Revenir en haut Aller en bas

Résolu Re: Analyse du site par W3C

Message par nadia cecile le Mar 19 Mar 2013 - 15:06

Bonjour Babyl,

Je viens de comprendre comment on mettait un message sur le forum...Un grand merci.

J'ai effectué les corrections et visiblement tout va bien.

Par contre j'ai encore des erreurs qui ressortent sur W3C
Sortie de validation: 7 erreurs

Code:
 Ligne 126, colonne 32 : il n'y a pas d'attribut "href données"
<Div class = "fb-like" data-href = " A9c ​​http://www.facebook.com/pages/La-villa-C% C3% ...

Vous avez utilisé l'attribut nommé ci-dessus dans votre document, mais le type de document que vous utilisez ne prend pas en charge cet attribut pour cet élément. Cette erreur est souvent causée par une mauvaise utilisation du type de document "Strict" avec un document qui utilise des cadres (par exemple, vous devez utiliser le type "transition" document pour obtenir la "cible" attribut), ou en utilisant des extensions fournisseur propriétaires tels que " marginheight "(ce qui est généralement fixée à l'aide de CSS pour obtenir l'effet souhaité à la place).

Cette erreur peut également se produire si l'élément lui-même n'est pas pris en charge par le type de document que vous utilisez, comme un élément non défini aura pas d'attributs pris en charge, dans ce cas, voir l'élément-undefined message d'erreur pour plus d'informations.

Solution: vérifier l'orthographe et la casse de l'élément et d'attribut, (Rappelez-vous XHTML est tout en minuscules) et / ou vérifie qu'ils sont accueillis dans le type de document choisi, et / ou utiliser les CSS au lieu de cet attribut. Si vous avez reçu ce message d'erreur lorsque vous utilisez l'élément embed d'incorporer un média flash dans une page Web, consultez la FAQ sur le point flash valide .

 Ligne 126, colonne 111 : il n'y a pas d'attribut "data-send"
...% C3% A9cile/132856323391257 "data-send = " false "data-layout =" button_count "données ...

Vous avez utilisé l'attribut nommé ci-dessus dans votre document, mais le type de document que vous utilisez ne prend pas en charge cet attribut pour cet élément. Cette erreur est souvent causée par une mauvaise utilisation du type de document "Strict" avec un document qui utilise des cadres (par exemple, vous devez utiliser le type "transition" document pour obtenir la "cible" attribut), ou en utilisant des extensions fournisseur propriétaires tels que " marginheight "(ce qui est généralement fixée à l'aide de CSS pour obtenir l'effet souhaité à la place).

Cette erreur peut également se produire si l'élément lui-même n'est pas pris en charge par le type de document que vous utilisez, comme un élément non défini aura pas d'attributs pris en charge, dans ce cas, voir l'élément-undefined message d'erreur pour plus d'informations.

Solution: vérifier l'orthographe et la casse de l'élément et d'attribut, (Rappelez-vous XHTML est tout en minuscules) et / ou vérifie qu'ils sont accueillis dans le type de document choisi, et / ou utiliser les CSS au lieu de cet attribut. Si vous avez reçu ce message d'erreur lorsque vous utilisez l'élément embed d'incorporer un média flash dans une page Web, consultez la FAQ sur le point flash valide .

 Ligne 126, colonne 131 : il n'y a pas d'attribut "data-layout"
391257 ... "data-send =" false "data-layout = " button_count "data-width =" 450 "data-sho ...

Vous avez utilisé l'attribut nommé ci-dessus dans votre document, mais le type de document que vous utilisez ne prend pas en charge cet attribut pour cet élément. Cette erreur est souvent causée par une mauvaise utilisation du type de document "Strict" avec un document qui utilise des cadres (par exemple, vous devez utiliser le type "transition" document pour obtenir la "cible" attribut), ou en utilisant des extensions fournisseur propriétaires tels que " marginheight "(ce qui est généralement fixée à l'aide de CSS pour obtenir l'effet souhaité à la place).

Cette erreur peut également se produire si l'élément lui-même n'est pas pris en charge par le type de document que vous utilisez, comme un élément non défini aura pas d'attributs pris en charge, dans ce cas, voir l'élément-undefined message d'erreur pour plus d'informations.

Solution: vérifier l'orthographe et la casse de l'élément et d'attribut, (Rappelez-vous XHTML est tout en minuscules) et / ou vérifie qu'ils sont accueillis dans le type de document choisi, et / ou utiliser les CSS au lieu de cet attribut. Si vous avez reçu ce message d'erreur lorsque vous utilisez l'élément embed d'incorporer un média flash dans une page Web, consultez la FAQ sur le point flash valide .

 Ligne 126, colonne 157 : il n'y a pas d'attribut "data-largeur"
Lse ... "data-layout =" button_count "data-width = " 450 "data-show-faces =" false "> </ div>

Vous avez utilisé l'attribut nommé ci-dessus dans votre document, mais le type de document que vous utilisez ne prend pas en charge cet attribut pour cet élément. Cette erreur est souvent causée par une mauvaise utilisation du type de document "Strict" avec un document qui utilise des cadres (par exemple, vous devez utiliser le type "transition" document pour obtenir la "cible" attribut), ou en utilisant des extensions fournisseur propriétaires tels que " marginheight "(ce qui est généralement fixée à l'aide de CSS pour obtenir l'effet souhaité à la place).

Cette erreur peut également se produire si l'élément lui-même n'est pas pris en charge par le type de document que vous utilisez, comme un élément non défini aura pas d'attributs pris en charge, dans ce cas, voir l'élément-undefined message d'erreur pour plus d'informations.

Solution: vérifier l'orthographe et la casse de l'élément et d'attribut, (Rappelez-vous XHTML est tout en minuscules) et / ou vérifie qu'ils sont accueillis dans le type de document choisi, et / ou utiliser les CSS au lieu de cet attribut. Si vous avez reçu ce message d'erreur lorsque vous utilisez l'élément embed d'incorporer un média flash dans une page Web, consultez la FAQ sur le point flash valide .

 Ligne 126, colonne 179 : il n'existe pas de données d'attribut "-show-faces"
Lse ... "data-layout =" button_count "data-width =" 450 "data-show-faces = " false "> </ div>

Vous avez utilisé l'attribut nommé ci-dessus dans votre document, mais le type de document que vous utilisez ne prend pas en charge cet attribut pour cet élément. Cette erreur est souvent causée par une mauvaise utilisation du type de document "Strict" avec un document qui utilise des cadres (par exemple, vous devez utiliser le type "transition" document pour obtenir la "cible" attribut), ou en utilisant des extensions fournisseur propriétaires tels que " marginheight "(ce qui est généralement fixée à l'aide de CSS pour obtenir l'effet souhaité à la place).

Cette erreur peut également se produire si l'élément lui-même n'est pas pris en charge par le type de document que vous utilisez, comme un élément non défini aura pas d'attributs pris en charge, dans ce cas, voir l'élément-undefined message d'erreur pour plus d'informations.

Solution: vérifier l'orthographe et la casse de l'élément et d'attribut, (Rappelez-vous XHTML est tout en minuscules) et / ou vérifie qu'ils sont accueillis dans le type de document choisi, et / ou utiliser les CSS au lieu de cet attribut. Si vous avez reçu ce message d'erreur lorsque vous utilisez l'élément embed d'incorporer un média flash dans une page Web, consultez la FAQ sur le point flash valide .

 Ligne 133, colonne 34 : il n'y a pas d'attribut "data-size"
<Div class = "g-plusone" data-size = " medium "de données d'annotation =" none "> </ div>

Vous avez utilisé l'attribut nommé ci-dessus dans votre document, mais le type de document que vous utilisez ne prend pas en charge cet attribut pour cet élément. Cette erreur est souvent causée par une mauvaise utilisation du type de document "Strict" avec un document qui utilise des cadres (par exemple, vous devez utiliser le type "transition" document pour obtenir la "cible" attribut), ou en utilisant des extensions fournisseur propriétaires tels que " marginheight "(ce qui est généralement fixée à l'aide de CSS pour obtenir l'effet souhaité à la place).

Cette erreur peut également se produire si l'élément lui-même n'est pas pris en charge par le type de document que vous utilisez, comme un élément non défini aura pas d'attributs pris en charge, dans ce cas, voir l'élément-undefined message d'erreur pour plus d'informations.

Solution: vérifier l'orthographe et la casse de l'élément et d'attribut, (Rappelez-vous XHTML est tout en minuscules) et / ou vérifie qu'ils sont accueillis dans le type de document choisi, et / ou utiliser les CSS au lieu de cet attribut. Si vous avez reçu ce message d'erreur lorsque vous utilisez l'élément embed d'incorporer un média flash dans une page Web, consultez la FAQ sur le point flash valide .

 Ligne 133, colonne 59 : il n'y a pas d'attribut "data-annotation"
<Div class = "g-plusone" data-size = "medium" données annotation = " none "> </ div>

Vous avez utilisé l'attribut nommé ci-dessus dans votre document, mais le type de document que vous utilisez ne prend pas en charge cet attribut pour cet élément. Cette erreur est souvent causée par une mauvaise utilisation du type de document "Strict" avec un document qui utilise des cadres (par exemple, vous devez utiliser le type "transition" document pour obtenir la "cible" attribut), ou en utilisant des extensions fournisseur propriétaires tels que " marginheight "(ce qui est généralement fixée à l'aide de CSS pour obtenir l'effet souhaité à la place).

Cette erreur peut également se produire si l'élément lui-même n'est pas pris en charge par le type de document que vous utilisez, comme un élément non défini aura pas d'attributs pris en charge, dans ce cas, voir l'élément-undefined message d'erreur pour plus d'informations.

Solution: vérifier l'orthographe et la casse de l'élément et d'attribut, (Rappelez-vous XHTML est tout en minuscules) et / ou vérifie qu'ils sont accueillis dans le type de document choisi, et / ou utiliser les CSS au lieu de cet attribut. Si vous avez reçu ce message d'erreur lorsque vous utilisez l'élément embed d'incorporer un média flash dans une page Web, consultez la FAQ sur le point flash valide .

Je ne sais absolument pas où et quoi modifier
Merci pour l'aide

Cordialement,
Nadia Cécile
avatar
nadia cecile
Touriste
Touriste

Bélier Buffle
Nombre de messages : 38
Age : 56
Ville (CP) : 17700
Date d'inscription : 13/02/2012

http://www.lavillacecile.fr

Revenir en haut Aller en bas

Résolu Re: Analyse du site par W3C

Message par B@byl le Mar 19 Mar 2013 - 15:28

Je viens de comprendre comment on mettait un message sur le forum...Un grand merci.
Super, je savais bien qu'on finirait par y arriver Very Happy
J'ai mis tes données de W3c dans des balises code pour éviter des beugs de page car elles contiennent du code.

Alors pour le W3C, là ça se complique, j'étais justement en train de faire des recherches concernant tes codes facebook et Google +1 car j'avais vérifié de mon côté ta validation W3C et j'ai vu que les erreurs ne s'arrêtaient pas à l'erreur 4 (dans ton premier message).

Il se trouve que Google comme FaceBook fournissent des codes contenant des attributs non valide au W3C ce qui fait râler beaucoup de monde et je les comprends.

Pour les autres erreurs c'était simple à corriger car c'était des erreurs de code mais là ce ne sont plus des erreurs de code mais l'utilisation de code, des attributs en l’occurrence (tous les "data-quelquechose"), non validés par le W3C.
Pour l'instant je n'ai pas trouvé de code de remplacement, je ne sais d'ailleurs pas si il en existe.

Je crains que tu ne sois obligée de faire un choix, soit les boutons FaceBook et Google mais pas de validation, soit la validation W3C mais sans les boutons.


_________________
B@byl
"La qualité d'une vie n'est pas dans l'accumulation mais dans le partage"
avatar
B@byl
Conservateur
Conservateur

Balance Serpent
Nombre de messages : 5872
Age : 64
Ville (CP) : Pas d'entraide par MP ou mail
Date d'inscription : 07/02/2007

http://www.assmat-nantes.fr/

Revenir en haut Aller en bas

Résolu Re: Analyse du site par W3C

Message par nadia cecile le Mar 19 Mar 2013 - 17:50

Merci pour toutes ces explications.
J'ai donc fait un choix, crucial il faut le dire.
J'ai supprimer les boutons facebook et google, et mis à la place un lien vers mes pages respectives.
La validation du "j'aime" de facebook et "+1" ne se fera plus sur mon site mais directement sur les pages concernées.
L'essentiel est de trouver une alternative.
Maintenant dans W3C tout est ok.

Merci pour tout et à bientôt pour de nouvelles aventures...
Cordialement,
Nadia Cécile

avatar
nadia cecile
Touriste
Touriste

Bélier Buffle
Nombre de messages : 38
Age : 56
Ville (CP) : 17700
Date d'inscription : 13/02/2012

http://www.lavillacecile.fr

Revenir en haut Aller en bas

Résolu Re: Analyse du site par W3C

Message par B@byl le Mar 19 Mar 2013 - 18:17

J'ai persisté dans mes recherches et elles ont été fructueuses.
j'ai trouvé du javascript pour valider les boutons FB et G+1 la source ici

Donc en clair pour le bouton "J'aime" de FB
tu mets ce code en remplaçant les étoiles (dans l'adresse) par ton adresse FB.
Fais bien attention à saisir tout le code en entier, tu as une scroll dans la fenêtre de code.
Code:
<div id="fb-root"></div>
<script type="text/javascript">(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/fr_FR/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<a class="fb-like" href="http://www.facebook.com/pages/*******/*******" id="fbbutton"  ></a>
<script type="text/javascript">
var ValidMe=document.getElementById("fbbutton");
ValidMe.setAttribute("data-send","false");
ValidMe.setAttribute("data-layout","button_count");
ValidMe.setAttribute("data-width","450");
ValidMe.setAttribute("data-show-faces","false");
</script>

Je viens de mettre en place chez moi et ça semble très bien fonctionner et la page reste valide.

Pour G+1 je peux faire pareil mais je n'ai pas le code que tu avais mis, si tu peux me le donner je ferais de même pour te renvoyer l’équivalent valide au W3C.

Edit Babyl : Finilement j'ai retrouvé celui de Google, tu mets ce code :
Code:
<script type="text/javascript">
  window.___gcfg = {lang: 'fr'};

  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script>

<div class="g-plusone"  id="google-button"></div>
<script type="text/javascript">
var ValidMe=document.getElementById("google-button");
ValidMe.setAttribute("data-size","medium");
</script>


Dernière édition par Babyl le Mar 19 Mar 2013 - 19:34, édité 1 fois

_________________
B@byl
"La qualité d'une vie n'est pas dans l'accumulation mais dans le partage"
avatar
B@byl
Conservateur
Conservateur

Balance Serpent
Nombre de messages : 5872
Age : 64
Ville (CP) : Pas d'entraide par MP ou mail
Date d'inscription : 07/02/2007

http://www.assmat-nantes.fr/

Revenir en haut Aller en bas

Résolu Re: Analyse du site par W3C

Message par nadia cecile le Mar 19 Mar 2013 - 19:09

J'ai remis les deux boutons.
Tout fonctionne parfaitement.
SUPER !...

Bonne soirée
Nadia Cécile
avatar
nadia cecile
Touriste
Touriste

Bélier Buffle
Nombre de messages : 38
Age : 56
Ville (CP) : 17700
Date d'inscription : 13/02/2012

http://www.lavillacecile.fr

Revenir en haut Aller en bas

Résolu Re: Analyse du site par W3C

Message par B@byl le Mar 19 Mar 2013 - 19:13

Merci et bonne soirée à toi aussi

Babyl

Edit : J'ai vu dans ton code source que pour celui de google tu n'as pas saisi la partie cachée, il y a une scroll là aussi, ça marche comme ça, mais bon c'est peut-être mieux de le mettre en entier, car c'est la partie qui permet de paramétrer la taille du bouton.


_________________
B@byl
"La qualité d'une vie n'est pas dans l'accumulation mais dans le partage"
avatar
B@byl
Conservateur
Conservateur

Balance Serpent
Nombre de messages : 5872
Age : 64
Ville (CP) : Pas d'entraide par MP ou mail
Date d'inscription : 07/02/2007

http://www.assmat-nantes.fr/

Revenir en haut Aller en bas

Résolu Re: Analyse du site par W3C

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum